Jump to content

  • Log in with Facebook Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account

Submit your paper to J Biol Methods today!
Photo
- - - - -

Cover slipping chamber slides


  • Please log in to reply
1 reply to this topic

#1 ari_doodle

ari_doodle

    member

  • Active Members
  • Pip
  • 10 posts
1
Neutral

Posted 30 May 2009 - 02:54 PM

I am using Nunc Lab-Tek 8 chamber slides to grow cells, fix them and then stain them for certain markers. When I tried to cover slip them I get bubble in the chambers and the permount inside the chambers does not seem to dry. I am using permount from Fisher. Is there a special technique to this or a special mounting media I should use? Thanks, Ari

#2 Rsm

Rsm

    Post Dog

  • Active Members
  • PipPipPipPipPipPipPipPipPipPip
  • 381 posts
8
Neutral

Posted 30 May 2009 - 07:37 PM

Yeah, chamber slides are quite difficult to mount without bubbles. Try this:
1.) use large volume of mounting media (200ul), pipet it onto the median line
2.) slowly lower your coverslip, starting from the short side. Hold it under one side with forceps.
3.) press onto coverslip with forceps to move bubbles to the boundaries of the well.
Most of the time I end up with one or two small bubbles in the corner of the well. That should be fine for microscopy.

Cheers,

Minna
I got soul, but I'm not a soldier




Home - About - Terms of Service - Privacy - Contact Us

©1999-2013 Protocol Online, All rights reserved.