Jump to content

  • Log in with Facebook Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account

Submit your paper to J Biol Methods today!
Photo
- - - - -

Problem concerning protein quantitation


  • Please log in to reply
2 replies to this topic

#1 barnacleman

barnacleman

    member

  • Active Members
  • Pip
  • 29 posts
0
Neutral

Posted 24 March 2009 - 07:59 PM

Hi, I use the Bradford method to measure protein concentration.

I use three replicates for each standard points and there are in total 6 standard pts I use (from 10 to 35 microgram per ml).

However, i discover that at the point 20 and 25 microgram per ml, the absorbance at 595nm is always not that consistent. Other points are absolutely fine and I have pipette cautiously and ensure that everything I added is correct. Does anyone know why is this so?

By the way, may I know which brand of Ovalbumin ur lab is using?

Thx in advance.

#2 T C

T C

    Veteran

  • Active Members
  • PipPipPipPipPipPipPipPipPipPip
  • 277 posts
0
Neutral

Posted 24 March 2009 - 08:30 PM

Hey,

I am not a gr8 fan of bradford for protein estimation. I prefer using BCA and the best is lowry. These assays are more sensitive. And I use the BSA which comes as a part of the assay kit. Otherwise weigh the sigma BSA for making standards.

Hope it helps

Best,
TC

Hi, I use the Bradford method to measure protein concentration.

I use three replicates for each standard points and there are in total 6 standard pts I use (from 10 to 35 microgram per ml).

However, i discover that at the point 20 and 25 microgram per ml, the absorbance at 595nm is always not that consistent. Other points are absolutely fine and I have pipette cautiously and ensure that everything I added is correct. Does anyone know why is this so?

By the way, may I know which brand of Ovalbumin ur lab is using?

Thx in advance.



#3 mdfenko

mdfenko

    an elder

  • Active Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,781 posts
132
Excellent

Posted 25 March 2009 - 06:43 AM

Hi, I use the Bradford method to measure protein concentration.

I use three replicates for each standard points and there are in total 6 standard pts I use (from 10 to 35 microgram per ml).

However, i discover that at the point 20 and 25 microgram per ml, the absorbance at 595nm is always not that consistent. Other points are absolutely fine and I have pipette cautiously and ensure that everything I added is correct. Does anyone know why is this so?

you pipette cautiously but is your pipette properly calibrated?

are you using the same pipette for the 20 and 25 ug/ml standards that you use for the other standards?

are those values near or at the lower and/or upper limit of the pipettes' range?
talent does what it can
genius does what it must
i do what i get paid to do




Home - About - Terms of Service - Privacy - Contact Us

©1999-2013 Protocol Online, All rights reserved.