Jump to content

  • Log in with Facebook Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account

Submit your paper to J Biol Methods today!
Photo
- - - - -

Problem in culturing MCF-7 cell line!


  • This topic is locked This topic is locked
20 replies to this topic

#16 Thapa

Thapa

    member

  • Active Members
  • Pip
  • 28 posts
0
Neutral

Posted 13 April 2009 - 05:11 PM

We here grew simply in DMEM and 10% FBS. They are pretty fine...
"Learning without thought is labor lost"

#17 refolder

refolder

    member

  • Active Members
  • Pip
  • 7 posts
0
Neutral

Posted 13 November 2009 - 04:47 AM

I use DMEM-F12 and 10% FCS for my MCF-7 cells, and they love it ;)

#18 jazmenia

jazmenia

    member

  • Active Members
  • Pip
  • 13 posts
1
Neutral

Posted 23 November 2009 - 07:30 AM

Hi,,
I grow MCF-7 in DMEM+10% FBS+ antibiotic and they are growing just fine.. they are kind of slow.. so what I do is increase the number of cells, i usually seed around 0.7 million cells in p-25 and they grow to full confulency within a week. you just control the number of cells seeded.

I never change the media the next day, usually do that the third day. and I never added insuline.. and they are growing just fine... and mine grow in epithelila layer form not doms

Edited by jazmenia, 23 November 2009 - 07:31 AM.


#19 isabellaweng

isabellaweng

    member

  • Active Members
  • Pip
  • 5 posts
0
Neutral

Posted 30 August 2010 - 07:43 PM

Hi,,
I grow MCF-7 in DMEM+10% FBS+ antibiotic and they are growing just fine.. they are kind of slow.. so what I do is increase the number of cells, i usually seed around 0.7 million cells in p-25 and they grow to full confulency within a week. you just control the number of cells seeded.

I never change the media the next day, usually do that the third day. and I never added insuline.. and they are growing just fine... and mine grow in epithelila layer form not doms

I also grow them in RPMI-1640 with 10% FBS, they grow well, the doubling time is silimar to ATCC reported. but when I set up the 96-well plate, treat with various doses of estradiol, they didn'grow well, and there are more and more dead cells,I have no idea what happened to these cells, Dose anyone have any idea? I repeated twice, same thing happened.Can anyone tell me how you do the experiment of MCF-7 cells treated with 17-beta estradiol?

#20 sushik

sushik

    member

  • Active Members
  • Pip
  • 5 posts
0
Neutral

Posted 04 October 2010 - 06:41 PM

For propagation, I usually grow my MCF-7s in DMEM w/ phenol red, 10% FBS, and 1% pen/strep/glu stock solution. I only grow them in phenol-red free medium when doing proliferation assays.

I rarely count cells while doing simple passaging, but based on personal experience it seems that the growth rate of MCF-7s is sensitive to cell density. A flask seeded at 10% confluency might take up to 2 weeks to reach 90% confluency, but a flask seeded at ~20% confluency seems to reach 90% confluency in about 3 days.

#21 ralfstevens

ralfstevens

    member

  • Members
  • Pip
  • 1 posts
0
Neutral

Posted 09 August 2011 - 06:50 AM

Great! I was literally just going to post the same question.

Wuahaha have you actually completed this now? I'm curious to see if everything worked out. I'm back in the lab tomorrow so this will be on top of my list.

When I tried last week I didn't use insulin. Curious to see what happened with you?

I did find a great article on RPMI on Cell Biology a week or so ago. I'd recommend having a look, some great stuff on there. I'll check back later.

Cheers,
Ralf




Home - About - Terms of Service - Privacy - Contact Us

©1999-2013 Protocol Online, All rights reserved.