Jump to content

  • Log in with Facebook Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account

Submit your paper to J Biol Methods today!
Photo
- - - - -

MCF-7 in cytotoxicity assay


  • Please log in to reply
2 replies to this topic

#1 Stone

Stone

    member

  • Active Members
  • Pip
  • 9 posts
0
Neutral

Posted 19 May 2010 - 05:30 PM

Hi!

Im having problems with my MCF-7 cells...

I seed the cells in a microplate and let them to atach for 24h. Then, I put my drugs to test and let more 24h.
When I wash the cells I notice that they detach from the well... The monolayer sometimes seems to fold.

I already worked with Vero cells and I didn't have this problem... And also I know (think) now that is not a error in the wash step.

What could be wrong? It could be the type of plate (I used Costar)? Should I use some substrate for the cells attachment?

Edited by Stone, 19 May 2010 - 06:09 PM.


#2 bob1

bob1

    Thelymitra pulchella

  • Global Moderators
  • PipPipPipPipPipPipPipPipPipPip
  • 5,710 posts
398
Excellent

Posted 19 May 2010 - 05:59 PM

Different cell lines behave differently. MCF-7 are not particularly strongly attached to their substrate. You could try gelatin (collagen) coating the wells.

#3 Stone

Stone

    member

  • Active Members
  • Pip
  • 9 posts
0
Neutral

Posted 19 May 2010 - 06:40 PM

Different cell lines behave differently. MCF-7 are not particularly strongly attached to their substrate. You could try gelatin (collagen) coating the wells.


Thanks for the reply!

I was wondering why the MCF-7 looks well attached at the cell culture flask and not in the microplate..




Home - About - Terms of Service - Privacy - Contact Us

©1999-2013 Protocol Online, All rights reserved.